menu
Partilhar

Como comparar duas colunas de dados no Excel

Por Daniela Amadeu. Atualizado: 20 janeiro 2017
Como comparar duas colunas de dados no Excel

O Excel como é sabido é uma ferramenta que possui uma linguagem de programação própria, onde é possível fazer somas, cálculos mais complicados e comparar dados entre colunas. Em casos onde o excel é usado para comparar dados, é essencial que uma terceira coluna mostre os resultados repetidos. Se você quer saber como comparar duas colunas de dados no Excel, leia o artigo completo aqui no UmComo.

Também lhe pode interessar: Como calcular a média ponderada no Excel
Passos a seguir:
1

O exemplo dado abaixo para comparar duas colunas de dados no Excel foi feito com o excel 2013. No entanto as funções serão iguais em todas as versões do excel.

2

Primeiro selecione a quantidade de linhas e colunas que deseja. Neste caso pretendemos comparar duas colunas no Excel, mas pode selecionar as colunas que quiser.

Como comparar duas colunas de dados no Excel - Passo 2
3

E depois com o botão direito do mouse clique sobre uma célula qualquer e desça até a opção “Formatar células”.

Como comparar duas colunas de dados no Excel - Passo 3
4

Irá aparecer um quadro para você adicionar bordas a sua coluna, aqui foi escolhido borda no contorno e bordas internas.

Como comparar duas colunas de dados no Excel - Passo 4
5

Agora insira os valores que deseja comparar nas duas colunas.

6

Depois, clique em Fórmulas -> Lógica e selecione o operador lógico “SE”.

Como comparar duas colunas de dados no Excel - Passo 6
7

Em “SE” insira a seguinte fórmula: =SE(A1;$C$1:$C$10;0));"";A1). Fazendo as alterações necessárias nas linhas e colunas, ou seja, terá que introduzir os dados das linhas e colunas que selecionou.

Como comparar duas colunas de dados no Excel - Passo 7
8

Arraste a fórmula para baixo para que ela seja aplicada às demais linhas e pronto, o resultado irá aparecer, cada linha da coluna B irá mostrar os números que estão repetidos na coluna A e coluna C, neste exemplo. Lembrando que a formatação do código apresentado acima para fazer a comparação tem que estar de acordo com a linha e a coluna em que os dados foram inseridos, caso contrário haverá erro e você não conseguirá executar a sua fórmula de comparação.

Como comparar duas colunas de dados no Excel - Passo 8
9

E agora já sabe como comprar duas colunas no Excel? Deixe seu comentário e se tiver alguma sugestão não hesite em dizer-nos.

Se pretende ler mais artigos parecidos a Como comparar duas colunas de dados no Excel, recomendamos que entre na nossa categoria de Software.

Escrever comentário

O que lhe pareceu o artigo?
5 comentários
A sua avaliação:
Antonio
Excelente site
A sua avaliação:
Felipe Pandolfi
Muito obrigado pelo Post....Ajudou muitooo!!!!
Editor umComo.com.br
Oi Feline! Que bom que as dicas te ajudaram. Continue acompanhando nossos artigos, valeu pelo comentário :)
A sua avaliação:
Wenderson Rodrigues
=SE(ÉERROS(CORRESP(A35;$C$2:$C$39001;0));"";A35)

inserir a formula entre as colunas checadas.
wilson
copiei as planilhas exatamente como está e não funcionou...
Pedro Gonga
quero comparar duas colunas de ficheiros diferentes como faço

Como comparar duas colunas de dados no Excel
1 de 7
Como comparar duas colunas de dados no Excel

Voltar ao topo da página